All maintenance is completed and systems are all operational.
Posted Jun 28, 2025 - 10:28 EDT
Update
Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Jun 28, 2025 - 10:26 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 28, 2025 - 09:00 EDT
Scheduled
We will be performing regular infrastructure updates to enhance system performance and reliability. This maintenance is scheduled for Saturday, June 28th at 9AM EST and is expected to last approximately 2 hours. During this window, access to our product may be temporarily unavailable. We apologize for any inconvenience and appreciate your understanding.
Posted Jun 13, 2025 - 16:04 EDT
This scheduled maintenance affected: Nintex Apps (AWS) and Cloud Data Service - US.