We would like to inform you that the ongoing maintenance window has been extended in order to ensure completion of updates. The new expected completion time is 12:30 PM EST. We apologize for any inconvenience this may cause and appreciate your patience as we continue working to improve our services.
Posted Feb 15, 2025 - 11:25 EST
Update
Scheduled maintenance is currently in progress. We will be extending the maintenance window to 11:30AM EST to continue with maintenance. We will provide any additional updates as necessary.
Posted Feb 15, 2025 - 10:55 EST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 15, 2025 - 09:00 EST
Scheduled
We will be performing infrastructure and database updates to enhance system performance and reliability. This maintenance is scheduled for Saturday, February 15th at 9AM EST and is expected to last approximately 2 hours. During this window, access to our product may be temporarily unavailable. We apologize for any inconvenience and appreciate your understanding as we work to improve our services.
Posted Jan 16, 2025 - 09:48 EST
This scheduled maintenance affected: Nintex Apps (AWS).